Sellbrite Degraded Performance
Incident Report for Sellbrite
Resolved
This incident has been resolved, thank you for your patience.
Posted Dec 12, 2022 - 08:28 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2022 - 07:33 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 12, 2022 - 07:24 PST
Investigating
We are currently investigating reports of degraded performance and issues ingesting orders into ShipStation.
Posted Dec 12, 2022 - 07:16 PST
This incident affected: Sellbrite App.