Sellbrite Performance Issues
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 15:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2024 - 13:32 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2024 - 11:02 PDT
Update
We are continuing to investigate this issue.
Posted Jun 26, 2024 - 11:01 PDT
Investigating
Sellbrite is experiencing multiple issues that are affecting its functionality. We are seeing reported issues ranging from listings publishing, orders being imported, and inventory updating. We are actively working to identify and resolve these problems
Posted Jun 26, 2024 - 07:44 PDT
This incident affected: Sellbrite App.