Unable to publish Etsy listings

Incident Report for Sellbrite

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 13:54 PDT

Identified

Sellbrite is currently experiencing an issue with publishing Etsy listings due to a recent Etsy update requiring a 'Processing Profile' to be attached to all listings. Our team is actively working to resolve this as quickly as possible.
Posted Sep 29, 2025 - 16:43 PDT
This incident affected: Sales Channels (Etsy API).