You should see your Amazon channel reconnected again. If not, please try clicking the "Reconnect" button in your channel settings. If you are still seeing issues, please reach out to support@sellbrite.com.
Posted Feb 20, 2026 - 07:06 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 20, 2026 - 06:39 PST
Monitoring
A fix has been implemented, and we are monitoring the results. To get your Amazon channel reconnected, you will need to go to your channel settings page for Amazon and click the "Reconnect" button. If you need assistance, please reach out to support@sellbrite.com
Posted Feb 20, 2026 - 06:39 PST
Investigating
We are aware of the issue with Amazon connections for some users. Our team is actively investigating the issue and working to resolve it as quickly as possible. Thank you for your patience.
Posted Feb 20, 2026 - 05:37 PST
This incident affected: Sales Channels (Amazon API).