Etsy API Image Issues
Incident Report for Sellbrite
Resolved
Our engineers have implemented a long-term solution to this issue. Thank you for your understanding.
Posted May 12, 2020 - 16:30 PDT
Monitoring
We have identified an issue with the Etsy image API that is preventing our listings from fully publishing. Our team has worked all day to address the issue and at this time believe that the problem resides on the remote systems.

When publishing an Etsy listing you may encounter an error and see that the images do not appear on Etsy. If this occurs wait a few minutes and try to republish the listing. If you have listings that have already published and appear to be missing data in Sellbrite, wait some time and click the "Sync from Etsy" button on the listing and that should reset the data.
Posted May 08, 2020 - 18:00 PDT
This incident affected: Sales Channels (Etsy API).