Maintenance Issue
Incident Report for Sellbrite
Resolved
Our efforts were successful and all systems are back to full operation.
Posted May 23, 2020 - 11:54 PDT
Monitoring
We have taken steps to address the issue and are monitoring the situation.
Posted May 23, 2020 - 11:07 PDT
Identified
A regular maintenance operation ran into trouble last night around 10pm causing high load on a subsystm. Some merchants may experience site slowness until we are able to address the problem.
Posted May 23, 2020 - 10:23 PDT
This incident affected: Sellbrite App.