Sellbrite - issues updating payment methods
Incident Report for Sellbrite
Resolved
This incident has been resolved, thank you for your patience.
Posted Mar 21, 2024 - 09:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 09:00 PDT
Identified
The issue has been identified and a fix has been implemented.
Posted Mar 21, 2024 - 08:55 PDT
Investigating
Some merchants may experience issues when updating payment methods via the Payment Info area. We are currently investigating the issue. Regular recurring subscription charges and upgrades/downgrades should not be affected by this issue.
Posted Mar 21, 2024 - 06:58 PDT
This incident affected: Sellbrite App.