Amazon API
Incident Report for Sellbrite
Resolved
Amazon has fixed the issue on their API.
Posted May 28, 2020 - 17:07 PDT
Identified
Amazon started experiencing issues with their Product API at 1:30pm and it is affecting some of our merchants. We are taking measures to support our merchants during this time.
Posted May 28, 2020 - 14:38 PDT
This incident affected: Sales Channels (Amazon API).