Etsy Channel Connection Issues

Incident Report for Sellbrite

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 13:26 PST

Monitoring

A fix has been implemented and we are monitoring the results. If your Etsy channel is disconnected please attempt to reconnect it now.
Posted Feb 10, 2026 - 11:40 PST

Identified

The issue has been identified and a fix is being worked on.
Posted Feb 10, 2026 - 10:14 PST

Investigating

We have received multiple reports of the channel connection for Etsy dropping - our Engineering team is investigating and we will provide updates as soon as possible.
Posted Feb 10, 2026 - 10:13 PST
This incident affected: Sales Channels (Etsy API).