Sellbrite - issues loading and rendering app
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 13:07 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2022 - 12:54 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2022 - 12:40 PST
Investigating
We are currently investigating reports of the Sellbrite app rending incorrectly or not loading at all. Our engineering teams are aware of the issue and we hope to have a fix ASAP.
Posted Nov 21, 2022 - 12:28 PST
This incident affected: Sellbrite App.