ShipEngine integration - issues selecting rates
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 11:32 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2024 - 10:34 PDT
Investigating
We are receiving reports of issues with selecting USPS rates via ShipEngine inside the Sellbrite app and are currently investigating.
Posted Oct 01, 2024 - 06:56 PDT
This incident affected: ShipEngine.