Sellbrite App - Degraded Performance

Incident Report for Sellbrite

Resolved

Performance has recovered, however we are continuing to monitor for further issues.
Posted Oct 26, 2022 - 07:03 PDT

Monitoring

Our engineering team has implemented a change to improve performance across the app. We will continue to monitor in-app performance for further issues.
Posted Oct 25, 2022 - 18:42 PDT

Investigating

We are currently investigating reports of slow or stuck loading of pages, elements and requests within the app.
Posted Oct 25, 2022 - 10:35 PDT
This incident affected: Sellbrite App.