Sellbrite Degraded Performance
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 09:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2023 - 08:43 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 27, 2023 - 08:39 PDT
Investigating
We are receiving some reports of slow or failed loading of pages within the app. Our engineering team has been alerted and we hope to have a resolution soon.
Posted Jul 27, 2023 - 08:06 PDT
This incident affected: Sellbrite App.