System issue with shipping partner preventing label purchases
Incident Report for Sellbrite
Resolved
Partner has resolved the issue. Shipping labels should be purchasable again.
Posted Jun 01, 2020 - 13:03 PDT
Monitoring
Our shipping partner is experiencing system issues, which is preventing shipping labels from being purchased within Sellbrite. We will be monitoring the status. https://status.stamps.com/
Posted Jun 01, 2020 - 12:00 PDT
This incident affected: ShipEngine.