Delayed Sync Job
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Sep 13, 2019 - 06:47 PDT
Identified
Due to a back up in the work queues some of our sync jobs have been delayed. We have identified the issue and are working to clear it up immediately.
Posted Sep 13, 2019 - 06:24 PDT
This incident affected: Sellbrite App.