Database Issues
Incident Report for Sellbrite
Resolved
All systems working well.
Posted 4 months ago. Jul 17, 2018 - 21:32 PDT
Monitoring
We experienced a brief interruption in our database service. We immediately recovered and are proactively monitoring to prevent another interruption.
Posted 4 months ago. Jul 17, 2018 - 17:30 PDT
This incident affected: Sellbrite App.