Site Slowness
Incident Report for Sellbrite
Resolved
The site performance issues have been resolved.
Posted 2 months ago. Jun 15, 2019 - 17:01 PDT
Investigating
Some of our merchants may experience site slowness due to unusual activity. We are actively engaged in improving site performance.
Posted 2 months ago. Jun 14, 2019 - 14:45 PDT
This incident affected: Sellbrite App.