Site down - 400 error
Incident Report for Sellbrite
Resolved
The issue has been resolved.
Posted over 1 year ago. Jun 10, 2016 - 14:59 PDT
Monitoring
The issue has been resolved and we are monitoring performance.
Posted over 1 year ago. Jun 10, 2016 - 14:05 PDT
Identified
We've identified the issue for the outage and are working as quickly as possible to resolve it.
Posted over 1 year ago. Jun 10, 2016 - 13:39 PDT
Investigating
We're investigating the outage.
Posted over 1 year ago. Jun 10, 2016 - 13:15 PDT