Public Site Down
Incident Report for Sellbrite
Resolved
The code change that caused the issue has been reverted. We are currently investigating the root issue.
Posted about 2 months ago. Jul 02, 2018 - 16:24 PDT
Investigating
Our web hosts are seeing instability. We are working to resolve the issue.
Posted about 2 months ago. Jul 02, 2018 - 16:13 PDT
This incident affected: Sellbrite App.