Some Site Slowness
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted Nov 20, 2019 - 15:40 PST
Update
We've restored performance to the system.
Posted Nov 20, 2019 - 15:39 PST
Identified
We are experiencing a higher than normal load on one of our systems. This may affect a subset of our merchants. We have identified the issue and are managing it. More information will be provided as it becomes available. We apologize for any inconvenience.
Posted Nov 20, 2019 - 09:25 PST
This incident affected: Sellbrite App.