Degraded Performance
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 02, 2018 - 06:12 PDT
Monitoring
Performance improvements have been made to our database, and we are now monitoring.
Posted about 2 months ago. Oct 01, 2018 - 17:35 PDT
Investigating
We are getting reports of degraded performance of the Sellbrite app, and are investigating the issue.
Posted about 2 months ago. Oct 01, 2018 - 11:28 PDT
This incident affected: Sellbrite App.