Sellbrite app - issues retrieving rates for shipping labels
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted May 01, 2024 - 06:35 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 30, 2024 - 07:19 PDT
Update
We have confirmed that this issue was due to a recently-resolved incident with our label provider, ShipEngine, but are continuing to monitor for further issues.
Posted Apr 30, 2024 - 07:18 PDT
Monitoring
We see that our label provider has implemented a fix and shipping labels can be purchased again. If you’re still seeing an issue please contact support.
Posted Apr 30, 2024 - 07:11 PDT
Investigating
We are currently investigating reports of multiple merchants receiving errors when attempting to retrieve rates and purchase shipping labels.
Posted Apr 30, 2024 - 06:53 PDT
This incident affected: ShipEngine.