Slow page loading
Incident Report for Sellbrite
Resolved
We have a solution in place to prevent performance degredations in the short term with longer term solutions in progress.
Posted 3 months ago. Jan 24, 2019 - 16:58 PST
Identified
We identified the issue and are working to apply a solution.
Posted 3 months ago. Jan 24, 2019 - 13:51 PST
Investigating
We're currently experiencing slow data loading, in particular on the Dashboard page. We are investigating the issue.
Posted 3 months ago. Jan 24, 2019 - 13:37 PST
This incident affected: Sellbrite App.