Site Performance Issues
Incident Report for Sellbrite
Resolved
We have addressed the load issue and all systems have returned to full operational capacity.
Posted 12 days ago. Sep 07, 2019 - 07:28 PDT
Update
Our team continues to monitor and address the situation. We are actively working to address the issue and prevent further issues in the future.
Posted 13 days ago. Sep 06, 2019 - 14:18 PDT
Investigating
Currently select subsystems are experiencing greater than expected load and that is negatively impacting the system overall. Our engineers are actively addressing the load issue and have identified the cause. We will continue to work toward getting our systems back to top performance immediately.
Posted 13 days ago. Sep 06, 2019 - 10:47 PDT
This incident affected: Sellbrite App.