Slow response times
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 29, 2016 - 13:21 PST
Identified
We've identified the issue and are looking for ways to mitigate the problem. In the mean time we've been able to restore some amount of service.
Posted almost 2 years ago. Feb 29, 2016 - 10:47 PST
Investigating
We've noticed a degraded and are investigating the cause.
Posted almost 2 years ago. Feb 29, 2016 - 10:16 PST