System performance is slow
Incident Report for Sellbrite
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 04, 2016 - 18:09 PDT
Identified
We've identified some issues related to a system update that happened last night and we are working to correct the issues.
Posted over 1 year ago. Aug 04, 2016 - 13:51 PDT
Investigating
We are experiencing some issues that has reduced the performance of our system.
Posted over 1 year ago. Aug 04, 2016 - 11:42 PDT