High System Load
Incident Report for Sellbrite
Resolved
We adjusted the work schedule for our systems and everything has returned to normal.
Posted Jan 08, 2020 - 22:08 PST
Monitoring
Our systems are experiencing an unusually high amount of work. Sync times may be delayed as we work to resolve the issue.
Posted Jan 08, 2020 - 21:51 PST
This incident affected: Sellbrite App.