Site Slowness
Incident Report for Sellbrite
Resolved
We have rebalanced our systems to accommodate the unusual activity and system performance has returned to normal.
Posted 9 months ago. Dec 19, 2018 - 19:32 PST
Monitoring
Some of our merchants may experience site slowness due to unusual activity. We are actively engaged in improving site responsiveness.
Posted 9 months ago. Dec 19, 2018 - 15:02 PST
This incident affected: Sellbrite App.