Increased System Load
Incident Report for Sellbrite
Resolved
We added more hardware to the system and performance has improved. All systems are fully operational.
Posted Dec 02, 2019 - 17:25 PST
Identified
We're experiencing a much higher than usual system load. We're actively working to add more resources to process the load and improve performance.
Posted Dec 02, 2019 - 16:13 PST
This incident affected: Sellbrite App.