Degraded performance
Incident Report for Sellbrite
Resolved
The issue has been resolved and performance is back to normal.
Posted 3 months ago. Jun 26, 2018 - 11:19 PDT
Investigating
Currently investigating reports of degraded performance in the application. Will provide updates every 10 minutes.
Posted 3 months ago. Jun 26, 2018 - 11:17 PDT
This incident affected: Sellbrite App.