Stamps.com Outage
Incident Report for Sellbrite
Resolved
Stamps.com is back up and we have improved our error handling in the event of a future outage.
Posted 20 days ago. Jun 27, 2018 - 10:50 PDT
Monitoring
Stamps.com is having some issues. The result of this is that our merchants cannot currently create shipping labels. We are working to make this inconvenience have as little impact as possible.
Posted 20 days ago. Jun 27, 2018 - 09:32 PDT
This incident affected: Sellbrite App.